9 Replies Latest reply on Jun 12, 2013 8:28 AM by Nass Sil

    Yocto - Working with the Toolchain

    jparrish88 Level 1

      I just started using Yocto by Following How to Test Yocto for i.MX6 .

      Now I'd like to build another project with the build-derived toolchain or the ADT installer toolchain.

      I'd also like to use eclipse and the Yocto plugin.

       

      So the first thing I tried was the ADT, it looked like it would be the easier method.

      I followed the steps here: http://www.yoctoproject.org/docs/1.3/adt-manual/adt-manual.html#adt-intro-sectionhttp://www.yoctoproject.org/docs/1.3/adt-manual/adt-manual.html#adt-intro-sectionhttp://www.yoctoproject.org/docs/1.3/adt-manual/adt-manual.html#adt-intro-section

      In doing so I typed the commands bitbake adt-installer then the log showed that it had succeeded.

      So I found the ADT installer tarball in /build/tmp/deploy/sdk

      Extracted that to a folder in my ~/. then I ran the adt-installer script. I didn't change the configuration.

      That installed files to /opt/poky/1.3/.

      From there I should have been set to use the eclipse yocto plugin.

      In order to set up Eclipse and the Yocto plugin I followed these directions: http://www.yoctoproject.org/docs/1.3/dev-manual/dev-manual.html#adt-eclipsehttp://www.yoctoproject.org/docs/1.3/dev-manual/dev-manual.html#adt-eclipse

      I went with Juno and I installed the pre-built yocto plugin (I thought it would be the safest).

      After everything was installed, and two restarts later... I went into window -> preferences -> Yocto Project ADT

      This window let me set where my toolchain was being pulled from.

      I entered /opt/poky/1.3/ into both the toolchain root and the sysroot.

      In the drop down I'm suppose to select my toolchain.

      Screenshot-Preferences-ADT.png

      Here is where I found out I should have changed the adt install scripts configuration.

      It only showed that I could select either ARMv5te or i586.

      Obviously I screwed up. But I should be able to build using this toolchain. So I started a new project as the directions state.

      I build the project and it gives me this output:

      Screenshot-C-C++ - Eclipse-ADT.png

      Okay so I messed up the ADT install. Turns out the configuration built for the wrong platform.

       

       

      So then I tried to redirect eclipse to use my build derived toolchain.

      So I entered in bitbake: bitbake meta-ide-support

      It completed successfully and I saw a sysroot folder and an environment-setup file be placed in the /build/tmp directory.

      So I go back into the eclipse and I I reconfigure it for a build derived toolchain.

      But nothing appears in the toolchain drop down.

      Screenshot-Preferences-BD.png

      If I try to hit ok, even though my target arch is greyed out I get this.

      Screenshot-Yocto Project Configuration Error.png

       

      Here is the weird part, if I select standalone pre-built I get a toolchain in the drop down.

      However, I can't select apply or ok.

      Screenshot-Preferences-BD-SA.png

       

       

      That said, I'm not sure what else I can do to get the Yocto plug in to work.

      I then tried to just to use the environment-setup file now located in the /build/tmp directory to build a Makefile based project - Uboot.

      It failed by saying that the project was not setup. (Most likely this error is from my inexperience with compling uboot)

       

      Any help or advice would be well received. Thanks!

       

      I couldn't share it without you having to follow me.

      Daiane Angolini and OtavioSalvador